Lesson 10: unable to expand CBF doc tree


CAD practitioner
Hi experts,

Firstly I'd like to thank you for your great video about OCCT. It makes my life easier a lot indeed!

Back to my question, when I use DFBrowse to view CBF file structure using DRAW in the OCCT binaries built by myself, I cannot expand the tree, but when I use the DRAW in official binaries, the structure of the same file can be viewed correctly using DFBrowse.

What may be the reason for the issue in the OCCT binaries built by myself? I've attached the screenshot of my CMake configurations. Do I missing some modules?


  • cmake_config.png
    152 KB · Views: 10


Staff member
Hi @RockWithBoA,

I succeed in your problem reproducing on OCCT 7.6.0 (branch OCCT-760) with default flags of CMake configuration (like yours). At the same time, in version, downloaded from the site (https://dev.opencascade.org/release) it works as you wrote.

I checked on Windows, under VStudio 2019. Both, starting DRAWEXE from the studio and by using draw.bat, gives the same result: nothing is changed in the tree by click on the root item. At the same time on the release version we have:

I’ve tried correct it, but seems have not enough experience in Tcl. Only found that the next row of ‘src/DrawResources/dftree.tcl’ is responsible for connection to required double click:

‘ $tree1 tag bind Label <<TreeviewOpen>> [list DFTREE:Tree:Open $DDF_Browser $w]’

If I commented this row in the OCCT release sources, nothing happens in the tree. The behaviour is like the compiled version.

Regarging flags that should be switched ON/OFF to fix the problem. Official release has lots of flags switched ON. We may see it in custom.bat of the released version:


set HAVE_TBB=true

set HAVE_VTK=true

set HAVE_D3D=true

set HAVE_FFMPEG=true


set CHECK_QT4=true

set CHECK_JDK=true’

All of them seems not related to Tcl/Draw functionality. But, you may try switching them… I’ve not.


Staff member
'BUILD_Inspector' flag of OCCT really does not influence on ‘DFBrowse’ Tcl command, because it is responsible for preparing Qt-based OCCT tool. This tool is an alternative of ‘DFBrowse’ command, see manual in (https://dev.opencascade.org/doc/occt-7.6.0/overview/html/occt_user_guides__inspector.html, the plugin name is ‘DFBrowser’).

As attached on your CMake snapshot, you have now it switched ON and all Qt depenendencies are found. That means that you may use this inspector tool. To try this, just use the next rows in your draw executable:



and have fun) The same document is opened in the ‘DFBrowser’ plugin of the inspector.

The result on (OCC22788.cbf of opencascade-dataset-7.6.0) is the following:


CAD practitioner
Hi @natalia ,

Thank you for your help. It seems it's not quite easy to find out the cause, so I'd perfer to use INSPECTOR or the official one as a workaround.